We are continuing to monitor for any further issues.
Posted Jul 08, 2025 - 17:40 CEST
Monitoring
Our services have scaled to match an increase in traffic. Our engineers are monitoring the situation.
Posted Jul 08, 2025 - 17:37 CEST
Investigating
Many of our services are experiencing major outages. We are currently investigating the issue.
Posted Jul 08, 2025 - 17:24 CEST
This incident affected: AXIS Camera Station Edge (Create site, Secure Remote Access, User management, Device management, License management, Organization management, Live video, Video playback, Events and Intercom calls, General), AXIS Cloud Connect (Live Video), and AXIS Camera Station Pro (Secure Remote Access v2).