We are currently experiencing intermittent problem when performing recording playback using the ACS Edge PC client and in MySystems. ACS Edge Mobile app playback is not affected

Incident Report for Axis

Resolved

Problematic service was identified and fixed
Posted Jul 11, 2026 - 20:10 CEST

Investigating

We are currently investigating this issue.
Posted Jul 11, 2026 - 20:01 CEST
This incident affected: AXIS Camera Station Edge (Video playback).